You are here: Home Blog Setuptools and a failing bootstrap

Setuptools and a failing bootstrap

by Mike Cullerton — last modified Jul 09, 2013 12:15 PM
Filed Under:

After distribute and setuptools merged back together, I had a problem running bootstrap. Upgrading setuptools fixed the problem for me.

I used zopeskel 2.21.2 to install a development version of Plone, but got an error when I tried to bootstrap it.

michaelc@Cullerton$ ../bin/python bootstrap.py
Traceback (most recent call last):
  File "bootstrap.py", line 117, in <module>
    ws.require('zc.buildout' + VERSION)
  File "/Users/michaelc/plone_dev/decsys-26/lib/python2.6/site-packages/distribute-0.6.27-py2.6.egg/pkg_resources.py", line 690, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/Users/michaelc/plone_dev/decsys-26/lib/python2.6/site-packages/distribute-0.6.27-py2.6.egg/pkg_resources.py", line 588, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: setuptools>=0.7

 

Upgrading setuptools fixed the problem for me.

easy_install --upgrade setuptools

 

Hope this helps someone.


Reinout has a related post. http://reinout.vanrees.org/weblog/2013/07/08/new-setuptools-buildout.html

Document Actions

Different version of same error

Avatar Posted by Chris Crownhart at Jul 17, 2013 10:42 PM
I got a slightly different error:

$ ../env-2.7/bin/python2.7 bootstrap.py
Traceback (most recent call last):
  File "bootstrap.py", line 117, in <module>
    ws.require('zc.buildout' + VERSION)
  File "/mnt/zope/env-2.7/lib/python2.7/site-packages/distribute-0.6.24-py2.7.egg/pkg_resources.py", line 686, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/mnt/zope/env-2.7/lib/python2.7/site-packages/distribute-0.6.24-py2.7.egg/pkg_resources.py", line 588, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (setuptools 0.6c11 (/mnt/zope/env-2.7/lib/python2.7/site-packages), Requirement.parse('setuptools>=0.7'))

But, easy_install -U setuptools also fixed it.

Add comment

You can add a comment by filling out the form below. Plain text formatting.

Info
You are not logged in. You may optionally enter your username and password below. If you don't enter anything, this comment will be posted as 'Anonymous User'.
(Required)
(Required)
(Required)
Enter the word
 
 
Copyright © 2003-2017 Core Software Group | 303/809-1001 | Fort Collins, Colorado | All rights reserved.